Resolved
Issue has been resolved by our PSP partner.
Monitoring
Payment methods being activated again by the PSP and it seems like service is being restored slowly.
Identified
Issue confirmed on our current PSP Provider.
Investigating
We have identified an issue impacting our payment processing system (PSOP). This has been isolated to a specific edge case affecting our current Payment Service Provider (PSP).
Because the fix relies directly on our provider, eCabs Technologies has limited direct control over the technical resolution. However, our team is actively engaged with the partner's support leadership to secure frequent updates and establish an estimated time of arrival (ETA) for a resolution. We will post further updates here as soon as new information becomes available.